wake-up-neo.net

locale: ripristina le impostazioni perse

Per qualche strano motivo, ho perso alcune delle mie impostazioni locale. Sono riuscito a ripristinarne la maggior parte usando Sudo dpkg-reconfigure locales:

Perl: warning: Setting locale failed.
Perl: warning: Please check that your locale settings:
 LANGUAGE = (unset),
 LC_ALL = (unset),
 LANG = "en_US.UTF-8"
    are supported and installed on your system.
Perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Quindi sono bloccato con un valore mancante:

$ locale
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Qualche idea su come ripristinarli tutti?

Grazie,

Adamo

6
Adam Matan

Se hai eliminato alcuni file, prova a reinstallare il pacchetto locale:

apt-get install --reinstall locales

Potresti voler fare lo stesso per language-support- (your langcode), language-pack- (your langcode) -base e altri language pack (gnome, kde ...) per la tua lingua.

5
Xuacu

Succede anche a me di tanto in tanto. Non sono sicuro di cosa sia la causa, ma ho appena spento:

Sudo dpkg-reconfigure locales

E questo sembra risolverlo (per me)

8
Oli

Questo è quello che dovevo fare per risolvere questo problema:

Sudo apt-get install --reinstall language-support-en
5
Eric Johnson

Nessuna delle risposte fornite non mi ha aiutato, ma ho trovato questo:

http://ubuntuforums.org/showpost.php?p=12183173&postcount=6

e ha fatto il trucco.

2
Irek

Di tanto in tanto mi imbatto in questo problema e nessuna delle risposte di cui sopra mi aiuta. Ciò che realmente mi aiuta è l'aggiunta di quanto segue a/etc/default/locales

LANG="en_US.UTF-8"
LANGUAGE="en_US"
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=en_US.UTF-8
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES=en_US.UTF-8
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
1
Artem Pakk