wake-up-neo.net

Come aggiornare mod_wsgi all'ultima versione su Ubuntu 10.04?

Sul mio server Ubuntu è installata questa versione:

# dpkg -l | grep wsgi
ii  libapache2-mod-wsgi  2.8-2ubuntu1  Python WSGI adapter module for Apache

Come posso ottenere ltima versione 3. ?

4
webjunkie

Scarica e compila. C'è un buon readme README nel loro pacchetto sorgente. Ma puoi iniziare installando build-essential il sistema di base per la compilazione, quindi segui il readme

2
LassePoulsen

Sudo apt-get build-dep libapache2-mod-wsgi

E poi puoi costruire dalla fonte leggendo il readme

1
sagarchalise

Debian ha libapache2-mod-wsgi , ma questo non funzionerà su Ubuntu 10.04 perché dipende da libpython2.7 per il quale non esiste un pacchetto per 10.04.

Ho scaricato la fonte da qui :

$ wget http://modwsgi.googlecode.com/files/mod_wsgi-3.3.tar.gz

Quindi basta

./configure
make
Sudo make install
1
David Xia

Ho installato mod_wsgi per python 2.7. Ho eseguito il comando seguente per disinstallare 2.7 e installare 3.6 (my python).

Sudo apt-get install libapache2-mod-wsgi
0
esafresa

Ciò che ha funzionato per me è stato eseguire questo:

Sudo aptitude install libapache2-mod-wsgi
0
user434136