wake-up-neo.net

"@ React-navigation / native" kann nicht aus "App.js" aufgelöst werden - React Native + Wie löse ich?

undefined Modul @react-navigation/native kann nicht aus App.js aufgelöst werden: @ react-navigation/native konnte im Projekt nicht gefunden werden.

Wenn Sie sicher sind, dass das Modul vorhanden ist, führen Sie die folgenden Schritte aus: 1. Löschen Sie Watchman-Uhren: Watchman-Watch-Del-All. 2. Löschen Sie die Knotenmodule: rm -rf Knotenmodule und führen Sie die Garninstallation aus. 3. Setzen Sie den Metro-Cache zurück: Garnstart - Reset-Cache 4. Entfernen Sie den Cache: rm -rf/tmp/metro- * - node_modules\react-native\Libraries\Utilities\HMRClient.js: 307: 41 in showCompileError - node_modules\react-native\Libraries\Utilities\HMRClient.js: 228: 26 in client.on $ argument_1 - node_modules\eventemitter3\index.js: 181: 39 in emit - node_modules\metro\src\lib\bundle-modules\WebSocketHMRClient.js: 80: 20 in _ws.onmessage - node_modules\event-target-shim\dist\event-target-shim.js: 818: 39 in EventTarget.prototype.dispatchEvent - Knotenmodule\react-native\Libraries\WebSocket\WebSocket.js: 232: 27 in _eventEmitter.addListener $ argument_1 - node_modules\react-native\Libraries\vendor\emitter\EventEmitter.js: 190: 12 in emit - node_modules\react-native\Libraries\BatchedBridge\MessageQueue.js: 436: 47 in __callFunction - node_modules\react-native\Lib raries\BatchedBridge\MessageQueue.js: 111: 26 in __guard $ argument_0 - Knotenmodule\react-native\Libraries\BatchedBridge\MessageQueue.js: 384: 10 in __guard - Knotenmodule\react-native\Libraries\BatchedBridge\MessageQueue.js: 110: 17 in __guard $ argument_0 * [nativer Code]: null in callFunctionReturnFlushedQueue

"@ React-navigation/native" kann nicht aus "App.js" aufgelöst werden. Fehler beim Erstellen des JavaScript-Bundles. "@ React-navigation/native" kann nicht aus "App.js" aufgelöst werden. Fehler beim Erstellen des JavaScript-Bundles. "@ React-navigation/native" kann nicht aus "App.js" aufgelöst werden. Fehler beim Erstellen des JavaScript-Bundles.

"@ React-navigation/native" kann nicht aus "App.js" aufgelöst werden. "@ React-navigation/native" kann nicht aus "App.js" aufgelöst werden. Fehler beim Erstellen des JavaScript-Bundles. Fehler: React-Native in den Abhängigkeiten von package.json nicht gefunden. Fehler: In den Abhängigkeiten von package.json kann React-native nicht gefunden werden

Bildbeschreibung hier eingeben

Bitte hilf mir. E-Mail-ID: [email protected]

5
Sounak Roy
npm install @react-navigation/native

bei Verwendung von expo:

expo install react-native-gesture-handler react-native-reanimated react-native-screens react-native-safe-area-context @react-native-community/masked-view

Führen Sie auch aus:

npm install react-navigation
0
devELIOper