wake-up-neo.net

Wie kann ich PyQT4 für Python 2.7 installieren?

Ich versuche PyQT4 auf Python 2.7.9 zu installieren, ich bin unter Mac OS X, also habe ich versucht, es über Homebrew und Macports zu installieren, leider schien keiner von ihnen zu funktionieren.

Das habe ich versucht:

brew install python qt pyqt pyside pyside-tools

auch versucht:

brew install PyQT4

Auf Macports:

Sudo port install py27-pyqt4

Egal was ich tat, ich habe diesen Fehler bekommen:

>>>> import PyQT4
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named PyQT4

Was kann das Problem sein? Muss ich den env-Pfad für PyQT einstellen?

5
ShellRox

Lösung gefunden:

Ich habe PyQtX-Paket (PyQt binary für Mac OS X) von hier installiert.

und dann PYTHONPATH mit diesem angegeben:

export PYTHONPATH=/usr/local/lib/python2.7/site-packages:$PYTHONPATH

Nach der Eingabe von import PyQt4 hat es problemlos funktioniert. (Groß-/Kleinschreibung)

7
ShellRox

Das hat sich für mich herausgestellt: https://robonobodojo.wordpress.com/2017/02/08/installing-pyqt4-on-mac-osx/

Was war es brew install cartr/qt4/pyqt

0
o_ren