wake-up-neo.net

Wie installiere ich libpython2.7.so

Ich habe Python 2.6.6 unter installiert 

[17:50:21 [email protected]:~]# which python
/usr/local/bin/python

auch Python 2.7.6 um 

[17:51:12 [email protected]:~]# which python2.7
/usr/local/bin/python2.7

Aber libpython2.7.so fehlt

[17:48:52 [email protected]:~]# locate libpython2.6.so
/usr/lib64/libpython2.6.so
/usr/lib64/libpython2.6.so.1.0
/usr/lib64/python2.6/config/libpython2.6.so
[17:48:56 [email protected]:~]# locate libpython2.7.so
[17:49:02 [email protected]:~]#

Weiß nicht, wie ich das beheben kann.

kann jemand helfen ?

9
roy

Sie könnten es aus Quellen in root kompilieren:

yum -y install python-devel openssl openssl-devel gcc sqlite-devel

wget http://www.python.org/ftp/python/2.7.5/Python-2.7.5.tar.bz2
tar -xvjf Python-2.7.5.tar.bz2
cd Python-2.7.5
./configure --prefix=/usr/local/python2.7 --with-threads --enable-shared
make
make install altinstall

ln -s /usr/local/python2.7/lib/libpython2.7.so /usr/lib
ln -s /usr/local/python2.7/lib/libpython2.7.so.1.0 /usr/lib
ln -s /usr/local/python2.7/bin/python2.7 /usr/local/bin
/sbin/ldconfig -v

Testen Sie dann den Python-Test /usr/local/python2.7/bin/python2.7 -V

Und als normaler Benutzer:

echo "alias python='/usr/local/python2.7/bin/python2.7'" >> ~/.bashrc
source ~/.bashrc
python -V    

Viel Glück :) 

17
M-Gregoire

Für Pip benötigen Sie openssl. Bitte installieren Sie die folgenden Pakete, bevor Sie sich für pip Openssl.x86_64 entscheiden
openssl-devel.x86_64

0
Muneeb Rahman