wake-up-neo.net

Wie installiere ich boto?

Damit ich in meinen Python-Skripten damit arbeiten kann?

48
Worbis
  1. Falls nötig, installieren Sie pip:

    Sudo apt-get install python-pip

  2. Dann boto installieren:

    pip install -U boto

69
jslopez

Die Installation von Boto hängt vom Betriebssystem ab. Für Ubuntu können Sie beispielsweise den Befehl aptitude verwenden:

Sudo apt-get install python-boto

Oder Sie können den Boto-Code von der Website herunterladen und in das entpackte Verzeichnis verschieben, um es auszuführen 

python setup.py install
34
sheki
$ easy_install boto

Bearbeiten: pip ist jetzt bei weitem der bevorzugte Weg, um Pakete zu installieren

13
John La Rooy

wechseln Sie in das Verzeichnis boto-* und geben Sie python setup.py install ein.

Meiner Meinung nach ist es am besten, boto zu installieren:

pip install boto-1.6 

Dies stellt sicher, dass Sie den Boto-Gletschercode haben. 

1
James O'Rourke
  1. install pip: https://pip.pypa.io/de/latest/installing.html

  2. insatll boto: https://github.com/boto/boto

    $ git clone git: //github.com/boto/boto.git
    $ cd boto
    $ python setup.py installieren 

1
loveisbug

Beim Ausprobieren der 

pip install boto

befehl, ich stoße auf den Fehler 

ImportError: No module named pkg_resources

Um dies zu beheben, geben Sie einen anderen Befehl aus, um die Setuptools mit curl zu behandeln

curl https://bootstrap.pypa.io/ez_setup.py | python

Danach wird der folgende Befehl einwandfrei funktionieren.

pip install boto
1
darthvading

Wenn Sie sich auf einem Mac befinden, ist die einfachste Art der Installation die Verwendung von easy_install.

Sudo easy_install boto3
0
Ilsa

Wenn Sie boto bereits in einer Python-Version installiert haben und dann eine höhere Python-Version installieren, wird Boto von der neuen Python-Version nicht gefunden. 

Zum Beispiel hatte ich Python2.7 und installierte dann Python3.5 (beides beibehalten). Mein Skript unter python3.5 konnte kein Boto finden. "pip install boto" sagte mir, dass boto bereits in /usr/lib/python2.7/dist-packages installiert war.

So tat ich

pip install --target /usr/lib/python3.5/dist-packages boto

Dadurch konnte mein Skript unter Python3.5 Boto finden.

0
royappa