wake-up-neo.net

Scipy kann immer noch nicht installiert werden, da der fortran-Compiler nach der Installation von gcc unter Mac OS X fehlt

Ich habe diese Antwort gelesen und befolgt, um scipy/numpy/theano zu installieren. Es ist jedoch immer noch fehlgeschlagen, weil der Fortran-Compiler nach der Installation von gcc nicht mehr vorhanden war. Während HomeBrew den gcc-4.8 installierte, installierte es keine gfortran- oder g95-Befehle. Ich nehme an, dass gfortran nur ein Synonym von gcc ist, dann erstelle ich einen Symlink

$ cd /usr/local/bin
$ ln -s gcc-4.8 gfortran
$ pip install scipy

Dann erkennt es den Befehl gfortran, beschwert sich jedoch weiterhin über keinen Fortran-Compiler

customize Gnu95FCompiler
Found executable /usr/local/bin/gfortran
customize NAGFCompiler
Could not locate executable f95
customize AbsoftFCompiler
Could not locate executable f90
Could not locate executable f77
customize IBMFCompiler
Could not locate executable xlf90
Could not locate executable xlf
customize IntelFCompiler
Could not locate executable ifort
Could not locate executable ifc
customize GnuFCompiler
Could not locate executable g77
customize G95FCompiler
Could not locate executable g95
customize PGroupFCompiler
Could not locate executable pgfortran
don't know how to compile Fortran code on platform 'posix'
building 'dfftpack' library
error: library dfftpack has Fortran sources but no Fortran compiler found

Was soll ich sonst machen?

34
teddy

Behoben durch ein Upgrade von pip, obwohl ich gerade mein pip/virtualenv das erste Mal am selben Tag neu installiert habe.

(mypy)MAC0227: $ pip install --upgrade pip
...
(mypy)MAC0227: $ pip install theano
/Users/me/.virtualenvs/mypy/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:79: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
Requirement already satisfied (use --upgrade to upgrade): theano in /Users/me/.virtualenvs/mypy/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): numpy>=1.6.2 in /Users/me/.virtualenvs/mypy/lib/python2.7/site-packages (from theano)
Collecting scipy>=0.11 (from theano)
/Users/me/.virtualenvs/mypy/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:79: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning
  Downloading scipy-0.15.1-cp27-none-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (19.8MB)
    100% |████████████████████████████████| 19.8MB 23kB/s
Installing collected packages: scipy
Successfully installed scipy-0.15.1
37
teddy

Folgendes hat für mich funktioniert:

Sudo apt-get install gfortran

auf meinem System:

Ubuntu 15.10 (Linux 4.2.0-19-generic # 23-Ubuntu x86_64 x86_64 x86_64 GNU/Linux)

26

Es hängt von der gcc-Version ab. Überprüfen Sie Ihre gcc-Version:

Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) but 4.8.4-2ubuntu1~14.04 is to be installed

Aktualisieren Sie Ihre gcc-Version: http://ubuntuhandbook.org/index.php/2013/08/install-gcc-4-8-via-ppa-in-ubuntu-12-04-13-04/

0
Manoj Sahu