wake-up-neo.net

python mpl_toolkits Installationsproblem

Nach dem Befehl pip install mpl_toolkits erhalte ich die nächste Fehlermeldung:

Konnte keine Version finden, die die Anforderung mpl_toolkits erfüllt (aus Versionen:)

Keine übereinstimmende Verteilung für mpl_toolkits gefunden

Ich habe versucht zu googeln, aber nichts hilft. Wie kann ich das lösen?

31

Es ist nicht auf PyPI und sollte nicht über pipinstalliert werden. Wenn Sie matplotlib installiert haben, sollten Sie mpl_toolkits direkt importieren können:

$ pip install --upgrade matplotlib
...

$ python
>>> import mpl_toolkits
>>> 
44
alecxe

Es funktioniert nicht auf Ubuntu 16.04, es scheint, dass einige Bibliotheken in diesem Python-Installationspaket vergessen wurden. Sie sollten stattdessen den Paketmanager verwenden.

Lösung

Deinstalliere matplotlib von pip und installiere es erneut mit apt-get.

Python 2:

Sudo pip uninstall matplotlib
Sudo apt-get install python-matplotlib

Python 3:

Sudo pip3 uninstall matplotlib
Sudo apt-get install python3-matplotlib
9
Charlie Lutaud

wenn jemand ein Problem mit Mac hat, können Sie dies versuchen

Sudo pip install --upgrade matplotlib --ignore-installed six
1
Giulio Imperato

Ich kann aufgrund mangelnder Reputation keine Kommentare abgeben, aber wenn Sie unter Arch Linux arbeiten, sollten Sie in der Lage sein, die entsprechenden Bibliotheken direkt in den Arch-Repositorys zu finden. Zum Beispiel für mpl_toolkits.basemap:

pacman -S python-basemap
1
Jerry Sun