wake-up-neo.net

Ein kompakter Build schlägt fehl, da kein Multiarray importiert werden kann

Ich verwende Homebrew-Python bei Mavericks und versuche, die Nummer 1.8 zu bauen. Wenn ich versuche, numpy zu installieren, erhalte ich die folgende Fehlermeldung: https://Gist.github.com/ngoldbaum/8592039

Ich kann numpy 1.7.2 mit pip install numpy==1.7.2 erstellen, aber numpy 1.8 kann immer nicht mit demselben Traceback erstellt werden.

18
ngoldbaum

auf dem Mac:

1.) Entfernen Sie diese 2 Ordner manuell:

rm -rf /usr/local/lib/python2.7/site-packages/numpy/
rm -rf /usr/local/lib/python2.7/site-packages/numpy-1.10.4.dist-info/

hinweis: pip uninstall numpy hat bei mir nicht funktioniert, ich musste numpy manuell entfernen.

2.) installiere numpy erneut: pip install numpy

33
Brian

Dieses Problem wurde gelöst, indem Sie brew uninstall python löschten, den Inhalt von /usr/local/lib/python2.7/site-packages löschten, Python neu installierten und dann numpy neu erstellten.

3
ngoldbaum

Ich habe es gelöst, indem ich numpy deinstalliert und numpy mit pip neu installiert habe -

pip3 uninstall numpy

pip3 install numpy
0
vikash singh

Ich habe mein Problem damit gelöst: Python.exe.\Lib\site-packages\easy_install.py

0
Jose Solis Jr.