wake-up-neo.net

Downgrade auf Python 3.4 von 3.5

Ich möchte kivy ( link here ) für ein Projekt installieren. Wenn Sie jedoch Pip zum Installieren der Pakete verwenden, von denen es abhängig ist, erhalte ich die folgende Fehlermeldung:

Could not find a version that satisfies the requirement kivy.deps.sdl2 (from versions: )
No matching distribution found for kivy.deps.sdl2

Weitere Informationen auf der Website von kivy haben gezeigt, dass diese Bibliotheken Python 3.5 unter Windows 10 aufgrund eines grafischen Fehlers nicht unterstützen. Die Website sagt, dass Sie Python 3.4 benötigen, um es installieren zu können.

Was bringt die Frage: Wie installiere ich Python 3.4, wenn ich bereits Python 3.5 habe?

17
jdanaher

Deinstallieren Sie Python 3.5, indem Sie zur Systemsteuerung gehen, ein Programm deinstallieren und dann nach Python 3.5 suchen. Klicken Sie darauf und klicken Sie auf "Deinstallieren". Nach diesem Download Python 3.4. Ich kenne keine anderen Möglichkeiten, aber ich denke, das sollte funktionieren. 

8
prisno102030

Wenn Sie eine Anaconda-Installation haben, können Sie einfach Folgendes eingeben:

conda install python=3.4

Und es installiert 3.4, um 3.5 neu zu installieren, ist es

conda install python=3.5

Es funktioniert in weniger als einer Minute.

33
VectorVictor

Ich konnte Python 3.4 in einem separaten Verzeichnis installieren und dann einfach den Standardinterpreter in PyCharm ändern, um stattdessen das neue Verzeichnis mit 3.4 zu verwenden.

0
jdanaher