wake-up-neo.net

Installation von PHP7 und Apache2.4 - php7Apache2_4.dll Fehler unter Windows 10

Ich hatte gerade ein Windows 10 und nachdem ich meine php.ini und http.conf konfiguriert hatte, ging ich auf die Kommandozeile httpd.exe und erhielt diese Fehlermeldung:

httpd.exe: Syntax error on line 530 of C:/Apache/conf/httpd.conf: Cannot load C:/php/php7Apache2_4.dll into server: The specified module could not be found.

Ich weiß, dass sich diese Datei in diesem Ordner befindet. Ich habe sowohl die 64-Bit-Version von PHP als auch Apache installiert und weiß nicht, was los ist. 

8
Storm Parker

Prüfen Sie, ob Sie eine sichere Version von PHP installiert haben. Nicht Thread-sichere Version verursacht diesen Fehler.

Sie können die sichere Version von PHP hier herunterladen.

14
Kumar

Welche von VC kompilierte Version von Apache verwenden Sie? Auf php.net wird empfohlen, den Apache-Server von apachelounge.com in Kombination mit den threadsicheren PHP-Dateien zu verwenden.
Stellen Sie außerdem sicher, dass Sie C++ Redistributable Visual Studio 2015 installiert haben.
Wenn dies immer noch fehlschlägt, stellen Sie sicher, dass der Benutzer, der den Prozess startet, Zugriff auf das Dateisystem hat.

0
Kagome

während Sie PHP herunterladen, sollten Sie das ThreadSafe-Paket auswählen. Apache unterstützt nonThreadSafe nicht.

0
Atheek