wake-up-neo.net

Unterwebsites in the Multisite-Installation, den einen 404-Fehler in wp-admin auslösen IIS 7

Beim Versuch, auf den Abschnitt "wp-admin" der Unterwebsite zuzugreifen, treten Probleme auf, bei denen Unterwebsites einer Mehrfachwebsite (Neuinstallation von 3.9 und keine Plugins oder Designs) den Fehler 404 auslösen. Es läuft auf IIS7.

Wenn wir uns über http://www.meinewebsite.com/wp-admin anmelden und zur untergeordneten Site navigieren, versuchen wir, uns abzumelden, und es wird ebenfalls ein 404 ausgegeben.

Verwendete die Standard-web.config , für die Regeln zum erneuten Schreiben. Aber alle Unterseiten warfen 404-Fehler auf die CSS/JS-Dateien. Also habe ich die Regeln für das Neuschreiben ein wenig geändert, was Sie unten sehen können.

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
            <rules>
                <rule name="WordPress Rule 1" stopProcessing="true">
                    <match url="^index\.php$" ignoreCase="false" />
                    <action type="None" />
                </rule>
                <rule name="WordPress Rule 2" stopProcessing="true">
                    <match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
                    <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
                </rule>
                <rule name="WordPress Rule 3" stopProcessing="true">
                    <match url="^" ignoreCase="false" />
                    <conditions logicalGrouping="MatchAny">
                        <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                        <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                    </conditions>
                    <action type="None" />
                </rule>
                <rule name="WordPress Rule 4" stopProcessing="true">
                    <match url="^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
                    <action type="Rewrite" url=“{R:2}” />
                </rule>
                <rule name="WordPress Rule 5” stopProcessing="true">
                    <match url="^([_0-9a-zA-Z-]+/)?(wp-comments-post.*)” ignoreCase="false" />
                    <action type="Rewrite" url=“{R:2}” />
                </rule>
                <rule name="WordPress Rule 6” stopProcessing="true">
                    <match url="^([_0-9a-zA-Z-]+/)?([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                    <action type="Rewrite" url="{R:2}" />
                </rule>
                <rule name="WordPress Rule 7” stopProcessing="true">
                    <match url="." ignoreCase="false" />
                    <action type="Rewrite" url="index.php" />
                </rule>
            </rules>
        </rewrite>
    </system.webServer>
</configuration>

Fehlen mir andere Regeln zum Umschreiben oder muss ich sie ändern? Die Unterwebsites werfen also keine 404-Fehler auf, wenn sie zur Seite/wp-admin navigieren.

1
tokyovariable

Das Problem herausgefunden. Es war mit der generierten "Wordpress Rule 6". Es gab 2 identische reguläre Ausdrücke. Der zusätzliche reguläre Ausdruck wurde entfernt. Musste auch "Wordpress Rule 5" entfernen. Die Regeln neu nummerieren und jetzt funktioniert alles gut.

Hier ist der aktualisierte web.config:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
            <rules>
                <rule name="WordPress Rule 1" stopProcessing="true">
                    <match url="^index\.php$" ignoreCase="false" />
                    <action type="None" />
                </rule>
                <rule name="WordPress Rule 2" stopProcessing="true">
                    <match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
                    <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
                </rule>
                <rule name="WordPress Rule 3" stopProcessing="true">
                    <match url="^" ignoreCase="false" />
                    <conditions logicalGrouping="MatchAny">
                        <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                        <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                    </conditions>
                    <action type="None" />
                </rule>
                <rule name="WordPress Rule 4" stopProcessing="true">
                    <match url="^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
                    <action type="Rewrite" url="{R:2}" />
                </rule>
                <rule name="WordPress Rule 5" stopProcessing="true">
                    <match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                    <action type="Rewrite" url="{R:2}" />
                </rule>
                <rule name="WordPress Rule 6" stopProcessing="true">
                    <match url="." ignoreCase="false" />
                    <action type="Rewrite" url="index.php" />
                </rule>
            </rules>
        </rewrite>
    </system.webServer>
</configuration>
2
tokyovariable