wake-up-neo.net

Nicht kompatibel mit Ihrem Betriebssystem oder Ihrer Architektur: [email protected]

Ich verwende Ubuntu 15.04. Während Sie den folgenden Befehl ausführen:

npm install fsevents

Ich erhalte folgenden Fehler:

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: [email protected]
npm WARN [email protected] No repository field.

Hat jemand das gelöst?

51
randomuser

Beim Erstellen einer anderen Anwendung stand ich mit dieser Abhängigkeit vor demselben Problem.

Nur für das Wissen und für Menschen, die mit NPM nicht vertraut sind und sich daher nicht sicher sind, wie sich ihre Anwendungen verhalten werden: 

Da fsevents eine API in OS X ist, können Anwendungen sich für Benachrichtigungen über Änderungen an einem bestimmten Verzeichnisbaum registrieren . Laufen:

npm install --no-optional

Werde das tun, ohne Nachteile.

82
Cezar Augusto

Es ist kein Fehler, es ist nur eine Warnung: Es ist eine optionale Abhängigkeit.

9
JMM

Sie können npm anweisen, optionale Abhängigkeiten standardmäßig nicht mithilfe der folgenden Befehlszeile zu installieren:

npm config set optional false
3
Simon D

Bei der Installation von Redux war ich auch mit diesem Fehler konfrontiert:

$ npm install --save react-redux
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: [email protected]

Das Problem, das gelöst wurde, war das Hinzufügen von --no-optional (argument verhindert, dass optionale Abhängigkeiten installiert werden):

npm install --no-optional --save react-redux
            ^^^^^^^^^^^^^

Und jetzt ist es richtig installiert:

$ npm ls redux
[email protected] /home/me/projects/reduxproject
└── [email protected] 
0
fedorqui

Ich hatte das gleiche Problem mit der Abhängigkeit. Bitte überprüfen Sie die package.json-Datei und fügen Sie unter "devDependency" den Eintrag "typings": "^ 0.8.1" hinzu. vergessen Sie nicht, vor dem Komma ein Komma hinzuzufügen :) Hoffe, es wird das Problem lösen.

0
santosh bhoyar

Ich habe festgestellt, wenn Sie "Garn hinzufügen" verwenden. Das Garn schließt aus, die Fehler werden nicht ausgegeben.

0
Supa_dave72

Wenn Sie ERR bekommen! WARNUNG Eine wahrscheinliche Ursache für dieses Problem ist, dass Sie eine wirklich veraltete Version von NPM verwenden

Für mich habe ich in einen Server geschält und war wie "Warum funktioniert das nicht?"

npm ERR! Linux 4.4.0-130-generic
npm ERR! argv "/home/william/.nvm/versions/node/v4.4.3/bin/node" "/home/william/.nvm/versions/node/v4.4.3/bin/npm" "install"
npm ERR! node v4.4.3
npm ERR! npm  v2.15.1
npm ERR! code EBADPLATFORM

npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your operating system or architecture: [email protected]
npm ERR! notsup Valid OS:    darwin
npm ERR! notsup Valid Arch:  any
npm ERR! notsup Actual OS:   linux
npm ERR! notsup Actual Arch: x64

npm ERR! Please include the following file with any support request:
npm ERR!     /home/william/app/mcard-api/npm-debug.log

Es stellte sich heraus, dass dieser Server (den ich erst kürzlich erworben hatte) npm 2.15.1 ausgeführt hat. Ich habe nvm neu installiert und nvm installiert --lts hat es behoben.

0
csga5000