wake-up-neo.net

Eclipse-Fehler JVM wurde beendet. Beenden Sie den Code = 1/usr/Java70/jre/bin/java

Ich bekomme einen Fehler wie

JVM terminated. Exit code=1
/usr/Java70/jre/bin/Java
-Dosgi.requiredJavaVersion=1.7
-Xms512m
-Xmx1024m

Meine Java-Version ist:

Java version "1.7.0"
Java(TM) SE Runtime Environment (build pxa6470sr9-20150417_01(SR9))
IBM J9 VM (build 2.6, JRE 1.7.0 Linux AMD64-64 Compressed References 20150406_242981 (JIT enabled, AOT enabled)
J9VM - R26_Java726_SR9_20150406_1443_B242981
JIT  - tr.r11_20150401_88894
GC   - R26_Java726_SR9_20150406_1443_B242981_CMPRSS
J9CL - 20150406_242981)
JCL - 20150414_02 based on Oracle 7u79-b14

Meine Eclipse.ini:

-startup
plugins/org.Eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
--launcher.library
plugins/org.Eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140116-2212
-product
org.Eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
-showsplash
org.Eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.7
-Xms512m
-Xmx512m

Linux-Version:

LSB_VERSION=base-4.0-AMD64:base-4.0-noarch:core-4.0-AMD64:core-4.0-noarch:graphics-4.0-AMD64:graphics-4.0-noarch:printing-4.0-AMD64:printing-4.0-noarch
Red Hat Enterprise Linux Server release 6.6 (Santiago)

Warum erhalte ich diesen Fehler und wie kann ich ihn beheben? 

Java-JAR-Plugins/org.Eclipse.equinox.launcher_1.3.0.v20130327-1440.jar

Java: cairo-misc.c:380: _cairo_operator_bounded_by_source: Assertion `NOT_REACHED' failed.
JVMDUMP039I Processing dump event "abort", detail "" at 2015/06/30 21:51:32 - please wait.
JVMDUMP032I JVM requested System dump using '/root/Desktop/core.20150630.215132.10911.0001.dmp' in response to an event
JVMPORT030W /proc/sys/kernel/core_pattern setting "|/usr/libexec/abrt-hook-ccpp %s %c %p %u %g %t e" specifies that the core dump is to be piped to an external program.  Attempting to rename either core or core.11074.

JVMDUMP010I System dump written to /root/Desktop/core.20150630.215132.10911.0001.dmp
JVMDUMP032I JVM requested Java dump using '/root/Desktop/javacore.20150630.215132.10911.0002.txt' in response to an event
JVMDUMP010I Java dump written to /root/Desktop/javacore.20150630.215132.10911.0002.txt
JVMDUMP032I JVM requested Snap dump using '/root/Desktop/Snap.20150630.215132.10911.0003.trc' in response to an event
JVMDUMP010I Snap dump written to /root/Desktop/Snap.20150630.215132.10911.0003.trc
JVMDUMP013I Processed dump event "abort", detail "".
8
fscore

Das Problem war, dass bei der Navigation zu einem beliebigen Workitem in RTC dieser Fehler auftrat und Eclipse abstürzte. Grundsätzlich erschien die Benutzeroberfläche nicht oder nur zur Hälfte. Dies wurde durch Hinzufügen der folgenden Zeile in Eclipse.ini behoben:

-Dorg.Eclipse.swt.internal.gtk.cairoGraphics=false
4
fscore

Ich empfehle Ihnen dringend, webupd8 ppa zu verwenden. Verwenden Sie dazu die folgenden Befehle:

1 .Sudo add-apt-repository ppa:webupd8team/Java
2 .Sudo apt-get update
3 .Sudo apt-get install Oracle-Java8-installer

Dann, um es einzustellen:

4 .Sudo update-Java-alternatives -s Java-8-Oracle 

Der Vorteil ist die einfache Aktualisierung.

11
Suree

Dies kann passieren, wenn mehrere Java-Instanzen installiert wurden. Führen Sie den folgenden Befehl aus -

Sudo update-alternatives --config Java

Wählen Sie dann den richtigen Java-Pfad aus, und führen Sie die Eclipse-Anwendung erneut aus.

8
Anupam Bera

Versuchen Sie, Ihr Java-Paket in Eclipse.ini abzulegen

Wenn Sie Ubuntu verwenden, lautet der Java-Pfad im Allgemeinen/usr/lib/jvm. Sehen:

-vm
/usr/lib/jvm/Java-x-openjdk-amdxx/bin/Java
-vmargs

Denken Sie daran, -vmargs nach -vm zu setzen

3
Victor Jatobá

Also hatte ich sogar den gleichen Fehler, als ich den Eclipse Oxygen in mein System installierte. Ich habe das ganze Setup gemacht und entsprechend konfiguriert, aber als ich versucht habe, die Eclipse.desktop über die MENU-Optionen zu öffnen oder sogar Eclipse über das Terminal auszuführen, stieß ich auf den Fehler wie oben. Also hier was ich getan habe: - 

1) Ich habe Eclipse.ini geändert, indem ich Folgendes hinzufügte: - Dorg.Eclipse.swt.internal.gtk.cairoGraphics = false (immer noch kein Glück, ich hatte den gleichen Fehler)

2) Die Java-Version wurde aktualisiert, indem sie alternativ hinzugefügt wurde, indem diese Befehle im Terminal hinzugefügt wurden 

Sudo add-apt-repository ppa: webupd8team/Java

Sudo apt-get Update

Sudo apt-get installiert den Oracle-Java8-Installer

Ich hoffe es hilft!! :)

1

Dieser Fehler war mir aufgefallen, ich habe alle oben genannten Lösungen ausprobiert. Ich hatte auch versucht, die .ini-Datei zu entfernen. Auch das hat nicht geholfen FAZIT Es gibt einige Eclipse-Versionen, die Java-Versionen wie 7,8,9 .__ unterstützen. Daher müssen Sie Eclipse gemäß ur jdk .__ oxygen: Java8 Eclipse mars: Java7 Alle Java-Versionen sind aufwärtskompatibel  Image from Eclipse official page

0
yunus