wake-up-neo.net

Maven-Plugin in Eclipse - Settings.xml-Datei fehlt

Ich habe das Maven-Plugin für Eclipse installiert. Dann habe ich versucht den Index zu aktualisieren und erhalte folgende Fehlermeldung:

Index für zentrale | http: //repo1.maven.org/maven2 kann nicht aktualisiert werden

Beim Versuch, die Proxy-Einstellungen über Windows-Preferences-Maven-User-Einstellungen zu bearbeiten, stelle ich fest, dass es keine solche Datei gibt. Ich habe keine separate Maven-Installation und nur das Plugin. Könnte jemand helfen, das Problem zu lösen? Vielen Dank.

Prost A

Config: Helios Service Release 1 Org.maven.ide.Eclipse.feature (0.12.0.20101115-1102) "Maven-Integration für Eclipse"

33
emeralddove

Die Einstellungsdatei wird niemals automatisch erstellt. Sie müssen sie selbst erstellen, unabhängig davon, ob Sie eingebettete oder "echte" Maven verwenden.

Erstellen Sie es an der folgenden Stelle <your home folder>/.m2/settings.xml Z. C:\Users\YourUserName\.m2\settings.xml unter Windows oder /home/YourUserName/.m2/settings.xml unter Linux

Hier ist ein leeres Skelett, das Sie verwenden können:

<settings xmlns="http://maven.Apache.org/SETTINGS/1.0.0"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.Apache.org/SETTINGS/1.0.0
                      http://maven.Apache.org/xsd/settings-1.0.0.xsd">
  <localRepository/>
  <interactiveMode/>
  <usePluginRegistry/>
  <offline/>
  <pluginGroups/>
  <servers/>
  <mirrors/>
  <proxies/>
  <profiles/>
  <activeProfiles/>
</settings>

Wenn Sie Eclipse verwenden, um es zu bearbeiten, erhalten Sie bei der Bearbeitung eine automatische Vervollständigung.

Und hier ist die Maven settings.xml Referenzseite

80

Bei der Arbeit am Mac folgte ich der Antwort von Sean Patrick Floyd, der eine settings.xml wie oben in meinen Benutzerordner /Users/user/.m2/ legte.

Das hilft aber nicht. Also habe ich ein Terminal geöffnet und ein ls -la im Ordner angelegt. Das zeigte sich

[email protected]

daher können staff und everone die Datei zumindest lesen. Also habe ich mich gefragt, ob die Nachricht nicht falsch ist und ob die eigentliche Ursache das Fehlen von Schreibberechtigungen ist. Ich setze die Datei auf:

[email protected]

Das hat es geschafft. Die Nachricht ist verschwunden.

0
LuCio