wake-up-neo.net

Fehler: DEP6200: Bootstrapping 'Device' ist fehlgeschlagen. Gerät kann nicht gefunden werden

Ich habe jeden StackOverflow gelesen, den ich zu diesem Problem finden konnte, aber ich kann ihn immer noch nicht lösen.

Ich versuche, eine App auf einem tatsächlichen Gerät bereitzustellen (NICHTEmulator). Ich erhalte die folgende Fehlermeldung, wenn ich versuche zu bauen:

Severity    Code    Description Project File    Line
Error       Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device '30F105C9-681E-420b-A277-7C086EAD8A4E'.': 
SEHException - External component has thrown an exception.  App1

und

Severity    Code    Description Project File    Line
Error       Error : DEP6200 : Bootstrapping 'Device' failed. Device cannot be found.    App1    

Es ist erwähnenswert, dass ich von Windows 7 zu Windows 10 übergegangen bin. Es ist auch erwähnenswert, dass meinem Computer die IpOverUsbSvc.exe fehlte (nicht nur der Registrierungsposten, sondern der eigentliche Dienst fehlte). Konnte keine Möglichkeit finden, dies zurückzubekommen, also schickte mein Kollege die .exe und die DLLs und ich legte sie an seinen Ort. Der Dienst läuft jetzt und gibt keine Fehler mehr aus. Mein Gerät wird vom PC erkannt, es läuft Windows 10 Mobile (aber ich habe es auch mit einem Gerät unter Windows 8.1 versucht).

Spezifikationen am PC:

  • Windows 10 Pro (Build 10240) 
  • Verwenden von Visual Studio 2015 
  • UWP-Tools

Irgendwelche Vorschläge, um meinen Albtraum zu reparieren? Vielen Dank!

15
Whyser

Endlich gelang es, eine Lösung für diesen illusorischen Fehler zu finden.

Wenn ich die Windows Phone 8.1-Tools nicht installiert habe, könnte ich nicht auf ein ARM - Gerät (nicht einmal Windows 10 Mobile) bauen.

Mein Schritt zur Lösung dieses Problems war: Gehen Sie zur Systemsteuerung -> Programme und Funktionen -> Microsoft Visual Studio ... 2015 -> Ändern. Wählen Sie dann die Windows Phone 8.1-Tools aus.

Ziemlich sauer, dass man keine vernünftige Fehlermeldung bekommt, wenn solche Dinge fehlen.

6
Whyser

Schritte, die mir geholfen haben. Ich habe Windows 10 Mobile Build 10581 (und jetzt 10586) auf dem Telefon installiert

  1. Deaktivieren Sie den Entwicklermodus auf Ihrem Telefon. 
  2. Bereitstellen der App (UWP oder SL) über VS2015 -> Fehler.
  3. Aktivieren Sie den Entwicklermodus auf Ihrem Telefon.
  4. App (UWP oder SL) über VS2015 bereitstellen -> Arbeiten.

Wenn Sie ein anderes Gerät wechseln oder erneut anschließen, müssen Sie VS2015 schließen, erneut starten und erneut versuchen!

10
Maxim Nikonov

Ich sehe, es ist ein ziemlich alter Beitrag ... aber ich bekomme immer noch dieses Problem. In meinem Fall geschah dies, nachdem ich mich auf ein zweites Telefon gestellt hatte, das ich zum Testen hatte. Danach möchte VS 2017 nur noch auf diesem Telefon und nicht mehr auf dem anderen Telefon bereitgestellt werden. Wenn ich ein anderes Projekt starte, wird das andere Telefon erkannt und bereitgestellt (als Gerät unter Debug aufgeführt) Das Neustarten des Systems behebt dies ...

Wenn ich meinem Projekt ein weiteres Projekt als Referenz hinzufügen (wie eine Hintergrundaufgabe), kann ich nicht mehr die Geräte und Emulatoren auswählen, die beim Debuggen ausgewählt werden sollen. VS 2017 scheint sich dann einfach auf dem zuletzt ausgewählten Gerät zu implementieren ... (wirklich keine Ahnung, was das ist). Ich konnte die Auswahl an Emulatoren und Geräten noch nicht auf diese zurückholen. Ich habe nur die Optionen "Start" und "Neue Emulatoren herunterladen". Ich denke, das hat damit zu tun, dass VS den Typ des Referenzprojekts (wie zB arm/86/64) möglicherweise nicht kennt, da es nicht festgelegt ist (nicht erforderlich, da dies den Zweck des Referenzierens eines Projekts für dynamische Referenzen nicht zulässt) und nicht die kompilierte gerätespezifische Datei ...)

Hoffe es hilft jemandem ....

1
Theo

Anscheinend gibt es viele Probleme, die dieselbe Fehlermeldung verursachen.

Dieser funktionierte für mich Windows Phone bereitstellen Problem

Im Wesentlichen müssen Sie das Gerät von Windows entfernen/deinstallieren. Nachdem Sie das Gerät entfernt und wieder angeschlossen haben, werden das Gerät und die Treiber erneut installiert.

1
JeremyB

desktop -> Mein Computer -> Rechtsklick -> Verwaltung -> Dienst -> Starten Sie den Dienst Windows Phone IP über USB-Transport (IpOverUsbSvc), obwohl möglicherweise starttype als automatisch eingestellt ist

1
Ming

Ich hatte dieses Problem, nachdem ich mein Gerät auf win10 ver: 10.0.10581.0 aktualisiert hatte. Ich habe viele Dinge ausprobiert, aber nach der Installation der neuesten SDK und Emulatoren habe ich es endlich zum Laufen gebracht. Sie können versuchen, von dieser Seite SDK und Emulator zu installieren:

https://dev.windows.com/en-us/downloads/windows-10-developer-preview

Irgendwie waren die neuen Emulatoren in vs nicht sichtbar, sie wurden nach wenigen Neustarts sichtbar und dann begann das Debuggen von Geräten.

Es bleibt jedoch ein Problem von mir, dass vs stürzt, nachdem die Debug-Sitzung mit dem Gerät beendet wurde.

1
Waqas

Ich habe die vorhandene Version der App auf dem Gerät deinstalliert und erneut ausgeführt, und es funktionierte für mich

1
Durai Amuthan.H

Ich habe viele der vorgeschlagenen Lösungen ohne Erfolg ausprobiert.

Nachdem Sie das USB-C-Kabel von einem USB 3.1-Anschluss zu einem USB 2.0-Anschluss meines Computers geändert haben, wird der Fehler nicht mehr angezeigt. YMMV

1
Gyle Iverson

Ich habe diesen Fehler aus einem ganz einfachen Grund erhalten ... habe gerade eine neue Lösung geöffnet, die ich von GitHub heruntergeladen, F5 gedrückt und sie erhalten habe!

Ich hatte meine Build-Konfiguration in der Standardeinstellung "Debug-ARM" belassen, als ich zu "Debug-x64" wechselte, funktionierte es einwandfrei!

(Fügen Sie einfach einen weiteren Grund für die Vollständigkeit hinzu, der Ihren Fall wahrscheinlich nicht beeinflusst!)

1
Jens Fiederer

Versuchen Sie es mit einem anderen USB-Port. Es funktionierte

0
Volkan

Für den Fall, dass es für andere hilfreich ist ... Ich habe: DEP6701 Bootstrapping fehlgeschlagen ... Zugriff verweigert.

Dank der Kommentare hier habe ich nur dev-locked und dev-unlocked mein Handy (war ursprünglich dev-unlocked). Totally funktioniert jetzt (es hat einige Zeit gedauert, fehlende Frameworks zu installieren). Alles gut.

Vielen Dank

0
Jim

Eine weitere Sache könnte versucht werden. 

Deinstallieren Sie gegebenenfalls die vorhandene App und stellen Sie sie anschließend in Visual Studio bereit.

0
Fei Zheng