wake-up-neo.net

OpenCV 2.3 - Kompilierungsproblem - Undefinierte Referenz - Ubuntu 11.10

Vielen Dank im Voraus für jede Hilfe ...

Systeminfo: Ubuntu 11.10 (64 Bit) mit OpenCV 2.3 (heute installiert)

Ich versuche, sehr einfachen Code in OpenCV 2.3 zu kompilieren, erhalte jedoch einen merkwürdigen Fehler.

#include <opencv2/core/core.hpp>
#include <opencv2/highgui/highgui.hpp>

int main(){
  cv::Mat image=cv::imread("img.jpg");
  cv::namedWindow("My Image");
  cv::imshow("My Image",image);
  cv::waitKey(0);
  return 1;
}

howeverrrrrrrrrrrrrr, ich bekomme diese Fehlermeldungen ...

-SG41:~/Desktop$ g++ `pkg-config opencv --cflags --libs` -o test_1 test_1.cpp 
/tmp/ccCvS1ys.o: In function `main':
test_1.cpp:(.text+0x44): undefined reference to `cv::imread(std::basic_string<char,    std::char_traits<char>, std::allocator<char> > const&, int)'
test_1.cpp:(.text+0x8e): undefined reference to `cv::namedWindow(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, int)'
test_1.cpp:(.text+0xbc): undefined reference to `cv::_InputArray::_InputArray(cv::Mat const&)'
test_1.cpp:(.text+0xf0): undefined reference to `cv::imshow(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, cv::_InputArray const&)'
test_1.cpp:(.text+0x112): undefined reference to `cv::waitKey(int)'
/tmp/ccCvS1ys.o: In function `cv::Mat::~Mat()':
test_1.cpp:(.text._ZN2cv3MatD2Ev[_ZN2cv3MatD5Ev]+0x39): undefined reference to `cv::fastFree(void*)'
/tmp/ccCvS1ys.o: In function `cv::Mat::release()':
test_1.cpp:(.text._ZN2cv3Mat7releaseEv[cv::Mat::release()]+0x47): undefined reference to `cv::Mat::deallocate()'
collect2: ld returned 1 exit status
37
user1002414

Ich vermute mal, dass zumindest einige der Bibliotheken in der Ausgabe von

pkg-config opencv --libs

sind Archivbibliotheken. Es ist falsch, Archivbibliotheken vor Quellen zu setzen, die sie benötigen (in diesem Fall test_1.cpp): Die Reihenfolge der Quellen und Bibliotheken in der Linkzeile matters .

Versuchen

g++ -o test_1 test_1.cpp `pkg-config opencv --cflags --libs` 
73

Ich hatte das gleiche Problem, aber ich fand heraus, dass pkg-config opencv --cflags "-I/usr/include/opencv" anstelle von "-I/usr/include/opencv2" druckt Ubuntu? 

2
dividebyzero

Ich benutze cmake und hatte ähnliche Probleme.

Mit den cmake-Konfigurationsdateien ist etwas Seltsames los.

Für mich wurden die Probleme gelöst, indem man einfach OPENCV_FOUND auf TRUE und OpenCV_FOUND auf TRUE setzt.

Außerdem musste ich OpenCV_DIR auf/usr/local/share/OpenCV setzen.

Siehe auch CMake Fehler beim Konfigurieren von opencv

0
Tim Kuipers

Die Antwort von @EmployedRussian hat auch für mich funktioniert. Wenn Sie sich fragen, wie Sie diesen Befehl in Eclipse angeben können, verwenden Sie diesen Beitrag - 

https://www.Eclipse.org/forums/index.php?t=msg&goto=233377&

Statt gtk + hinzuzufügen, verwenden Sie opencv; Anstatt die neuen Flags zu 'Miscellaneous linker flags' hinzuzufügen, fügen Sie die neuen Flags am Ende nach $ {INPUT} in -.__ ein. Projekt-> Rechtsklick-> Eigenschaften- > C/C++ Build -> Einstellungen -> GCC C++ - Linker -> Experteneinstellungen: Befehlszeilenmuster

0
IEEE754