wake-up-neo.net

Wie kann ich den Microsoft Visual Studio-Fehler beheben: "Paket wurde nicht korrekt geladen"?

Ich habe Visual Studio 2012 und DevExpress 13.1 installiert. Beim Starten von Visual Studio wurde ein Fehler generiert, der durch das angefügte Bild angezeigt wird.

Das Paket 'Microsoft.VisualStudio.Editor.Implementation.EditorPackage' wurde nicht richtig geladen. 

Das Problem wurde möglicherweise durch eine Konfigurationsänderung oder durch die Installation einer anderen Erweiterung verursacht. Weitere Informationen erhalten Sie in der Datei 'C:\Benutzer\muss\AppData\Roaming\Microsoft\VisualStudio\11.0\ActivityLog.xml'.

Diese Fehlermeldung weiterhin anzeigen?

 Microsoft Visual Studio - The 'Microsoft.VisualStudio.Editor.Implementation.EditorPackage' package did not load correctly.

Dieser Fehler wird auch in Visual Studio 2017 angezeigt.

154
Dua Ali

Ich fing an, dies auf einer neuen Windows und Visual Studio 2013 Ultimate-Installation mit Update 2 zu sehen (obwohl andere auch über Updates 3 und 4 sowie die Professional-Version berichtet haben).

Um das Problem zu beheben, schließen Sie alle Visual Studio-Instanzen und löschen Sie dann alle Dateien im folgenden Ordner:

Visual Studio 2013

%localappdata%\Microsoft\VisualStudio\12.0\ComponentModelCache

Es hat gut für mich funktioniert. Danke an diesen Artikel .

Visual Studio 2015

%localappdata%\Microsoft\VisualStudio\14.0\ComponentModelCache

Visual Studio 2017

%localappdata%\Microsoft\VisualStudio\15.0_xxxx\ComponentModelCache
317
user_v
  • Schließen Sie Visual Studio.

  • Sichern und löschen Sie folgenden Pfad:

    C:\Users\{your_username}\AppData\Roaming\Microsoft\VisualStudio\11.0

  • Starten Sie Visual Studio neu als Admin, andernfalls kann der Ordner Roaming nicht von Visual Studio repariert werden.

39
Reza Ebrahimi

Versuchen Sie devenv /setup an der VS-Eingabeaufforderung mit Administratorrechten.

Ich hatte das gleiche Problem mit VS 2013 Ultimate. Ich habe die hier von Reza veröffentlichte Lösung ausprobiert, aber nicht funktioniert.

Schließlich konnte ich VS nicht schließen, es zeigte einen ähnlichen Dialog, als ich versuchte zu schließen, und es wurde nicht geschlossen. Ich habe folgendes ausprobiert: hier Fehlermeldung "Es wurden keine Exporte gefunden, die dem Constraint-Vertragsnamen entsprechen" . Weder.

Ich habe im Team Explorer-Fenster die Meldung "Seite 'somenumber" kann nicht gefunden werden "angezeigt. Auf diese Weise versucht und ich fand diese Antwort: Seite '312e8a59-2712-48a1-863e-0ef4e67961fc' mit Visual Studio 2012 nicht gefunden . Also führe ich devenv /setup auf der VS-Eingabeaufforderung mit Administratorrechten aus.

Es hat den Job gemacht. Alles ist jetzt gut.

Ich hoffe es hilft.

31
jbarrameda

Dieses Problem ist in Visual Studio 2017 (15.7.4) aufgetreten. Nachdem ich verschiedene Lösungen ausprobiert hatte, funktionierte dies letztendlich für mich: Schließen Sie alle VS-Instanzen, und führen Sie die Befehlszeile aus (möglicherweise mit Administratorrechten):

"devenv.exe/clearcache" und "devenv/updateconfiguration"

24
tdracz

Ich hatte ein ähnliches Problem und ging zu Systemsteuerung / Programme und reparierte die Visual Studio-Installation. Ich habe für mich gearbeitet.

9
Daniel

Lösung für Visual Studio 2017:

schritt 1: Visual Studio Cmd im Administratormodus öffnen (Siehe Startmenüpunkt: Eingabeaufforderung für Entwickler für VS 2017 - Verwenden Sie unbedingt: Als Administrator ausführen)

schritt 2: Wechseln Sie in den Ordner, in dem VS 2017 installiert ist. Beispiel:

cd C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise

(Sie können diesen Befehl in Ihre Eingabeaufforderung kopieren/einfügen. In Visual Studio Professional heißt der Ordner "Professional" anstelle von "Enterprise" usw.)

schritt 3: Kopieren Sie den folgenden Befehl

gacutil -if Common7\IDE\PublicAssemblies\Microsoft.VisualStudio.Shell.Interop.8.0.dll

drücke Enter..

es wird das Problem beheben ..

andernfalls können Sie wie oben beschrieben auch Folgendes zu GAC hinzufügen

Microsoft.VisualStudio.Shell.Interop.9.0.dll

Microsoft.VisualStudio.Shell.Interop.10.0.dll

Microsoft.VisualStudio.Shell.Interop.11.0.dll

8
dinesh kumar

Ich hatte Visual Studio 2013 Professional und bekam den gleichen Fehler. Ich konnte es erst entfernen, nachdem ich die Visual Studio-Installation repariert hatte. Es hat eine Weile gedauert, aber jetzt funktioniert es gut.

3
georger

Ich hatte das gleiche Problem. Versuchen Sie, sich an die neueste installierte Erweiterung zu erinnern. Ich lösche die neueste Erweiterung aus Erweiterungen und Updates und starte Visual Studio neu. und das Problem ist gelöst. Für mich lautet der Erweiterungsname Productivity Power Tools  

2
Elvin Mammadov

Dieses Problem ist auch nach der Installation von Telerik Reporting aufgetreten. Ich konnte keine Lösung in VS2013 starten und konnte VS2013 nicht schließen. Nach der Deinstallation des Berichtspakets und dem Löschen von Local/Roaming AppData für VS 11/12 wurde das Problem behoben.

2
alan

in Visual Studio 2015 gab es dasselbe Problem, nachdem ich mehrere Stunden meines Tages eine Antwort darauf gefunden hatte * Schließen Sie alle Visual Studio-Instanzen * und gehen Sie zu {AppData\Roaming\Microsoft\VisualStudio\14.0}. löschen Sie die Dinge darin .. *. * Starten Sie Visual Studio im Admin-Modus, um die darin enthaltenen Ordner zu reparieren.

1
Hasiya

Sie müssen die Datei devenv.exe.config in C:\Users\{user_name}\AppData\Local\Microsoft\VisualStudio\14.0\ finden und aktualisieren. (Oder C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\, abhängig vom Speicherort Ihrer devenv.exe-Datei.)

In diesem speziellen Fall sollten Sie Zeilen finden, die für System.Collections.Immutable umgeleitet werden, und newVersion von 1.1.36.0 auf 1.1.37.0 ändern. 

Der ursprüngliche Artikel lautet Wiederherstellen von Visual Studio 2015 nach dem Update 1 (Abhängigkeitstanz).

1
user3617831

Ich hatte das gleiche Problem und es wurde behoben, nachdem devenv /setup an der Eingabeaufforderung ausgeführt wurde.

1
Suneel VLN

VISUAL STUDIO 2017 Lösung für mich: 1. Schließen Sie VS 2. Lief es im "Run as Admin" -Modus.

Kein Problem mehr.

1
Doug Null

Basierend auf diesem Connect-Feedback wurde das Problem behoben, indem alle geöffneten Dokumente geschlossen und Visual Studio neu gestartet wurde. Ich benutze Visual Studio 2015.

1
Jan Zahradník

Beim Erstellen eines Projekts "Node.js" in Visual Studio 2015 ist auch der gleiche Fehler "NPM-Paket nicht korrekt installiert"...

Ich habe mein Problem durch zwei Schritte gelöst:

  1. Löschen Sie alle Dateien, die sich an diesem Ort befinden: 

    C:\Users\<Your User Name>\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache
    

    Starten Sie Visual Studio neu.

  2. Öffnen Sie Visual Studio und wählen Sie Menü Extras NuGet Package Manager Package Manager Settings → 

    Auf der linken Seite: Sie sehen eine Dropdown-Liste: Wählen Sie Node.js, Tools Npm ClearCache → * OK

Versuchen Sie dann erneut, das Projekt zu erstellen. Es hat mein Problem gelöst.

0
AkshayPorwal

Ich wollte nur erwähnen, dass ich einen ähnlichen Fehler in SQL Server Management Studio 2016 erhalten habe, wo ich ihn grundsätzlich ignorierte. Später habe ich Visual Studio (2015) gestartet, und dieser Fehler ist auch dort aufgetreten.

Ich habe die Antwort hier gesucht und gefunden, in der ich empfehle, Dateien aus dem Ordner zu löschen

%localappdata%\Microsoft\VisualStudio\14.0\ComponentModelCache

mappe. In meinem Fall war dieser Ordner jedoch leer.

Da ich mich erinnerte, dass ich den Fehler in Management Studio zuerst gesehen hatte, habe ich nachgeschaut, und es gab einen ähnlichen Ordner unter

%localappdata%\Microsoft\SQL Server Management Studio\13.0\ComponentModelCache

Dieser Ordner war nicht leer. Ich habe sowohl Visual Studio als auch Management Studio geschlossen und die Dateien aus diesem Ordner gelöscht.

Anschließend wurden Management Studio und Visual Studio ohne Fehler gestartet.

0
MisterAcoustic

Durch die Aktualisierung von VS2017 über das Visual Studio-Installationsprogramm wurde das Problem für mich behoben.

0
Michel47

Ich hatte dieses Problem nach der Installation von Crystal Reports für Visual Studio. Ich habe das Problem gelöst, indem ich alle Visual Studio-Instanzen geschlossen und Crystal Reports neu installiert habe.

0
egse

Ich hatte dieses Problem und Projekte wurden nicht richtig geladen oder besagten, dass sie migriert werden mussten. Die ActivityLog.xml zeigte einen Fehler mit einer bestimmten Erweiterung. Ich habe die Erweiterung deinstalliert und Visual Studio neu gestartet. Das Problem wurde gelöst.

0
Owen Pauling

Ich hatte das gleiche Problem und das Löschen des App-Datenverzeichnisses für Visual Studio 11.0 funktionierte für mich.

0
Griffo

Hatte das Vergnügen, dieses zufällige Problem in Visual Studio 2017 Enterprise zu erleben. Versuchte jede Lösung hier und funktionierte nicht, einschließlich der VS-Reparatur (was eine Weile dauert). Einige Stunden später dachte ich, ich sollte die ActivityLog.xml-Datei überprüfen.

 ActivityLog.xml 

Deinstallierte die anstößige Erweiterung von der 'Developer Command Prompt for VS2017' als Admin, da Visual Studio nach dem Öffnen einfriert und nichts angeklickt werden konnte.

Deinstallationsschritte - mit freundlicher Genehmigung von jessehouwing.net

  1. Suchen Sie die vsix-Datei, mit der Sie die Erweiterung installiert haben.
  2. Öffne es in deinem Lieblingsarchiv (meins ist 7-Zip).
  3. Holen Sie sich die Id der Erweiterung aus dem Identity -Knoten aus dem extension.vsixmanifest.
  4. Führen Sie (in meinem Fall) vsixinstaller /u:Microsoft.VisualStudio.LiveShare aus, um die Erweiterung zu entfernen.
0
Nhan

In meinem Fall lautet die Fehlermeldung "Das Paket 'IntelliCodeCppPackage' wurde nicht korrekt geladen. (VS2019)

IntelliCodeCppPackage

Ich habe das Problem mit diesen Schritten gelöst.

  • Deaktivieren Sie die Erweiterung "Visual Studio InttelliCode"
  • starten Sie Visual Studio neu
  • Aktivieren Sie diese Erweiterung erneut
0
boyukbas

Dieses Problem hatte ich auch mit Visual Studio 2013 Update 4. Nach dem erneuten Ausführen des Installationsprogramms für Update 4 und der Auswahl von Reparieren und dem Neustart des Computers ging das Problem jedoch nicht mehr vonstatten.

0
danludwig