wake-up-neo.net

Fehler "Subversion-Befehlszeilen-Clientversion ist zu alt" in Android Studio

Wenn ich ein Projekt in Android Studio öffne, wird diese Fehlermeldung angezeigt:

 Error

Wenn ich auf "Fix it" klicke, wird folgendes Fenster angezeigt:

 Fix it

Ich weiß nicht, was ich tun soll, weil TortoiseSVN 1.9.0 ausgeführt wird. Dies ist die neueste Version.

Was muss ich tun, um diesen Fehler zu beheben? Danke für Ihre Hilfe.

20
Triet Doan

Es ist nur ein Druckfehler: muss "zu neu" sein

Android Studio basierend auf Intellij IDEA, Intellij 14.1.4 kann svn 1.9.0 nicht verwenden

22
Lazy Badger

Intellij IDEA 14 arbeitet mit SVN 1.9, es wird nur eine Warnung angezeigt: https://youtrack.jetbrains.com/issue/IDEA-140754

5
lili

Svn 1.9-Befehlszeilen-Client sollte in IDEA funktionieren. Es wird nur eine Warnung (Sie können sie schließen) angezeigt Aktualisieren Sie die neue Version 14.1.5 von https://confluence.jetbrains.com/display/ IDEADEV/IDEA + 14.1 + EAP oder 15 EAP: https://confluence.jetbrains.com/display/IDEADEV/IDEA+15+EAP .

https://devnet.jetbrains.com/thread/471975

2
liubiqu

Wie Lazy Badger sagt, sollte es is too new sagen.

Das gleiche Problem unter Debian. Ich hatte die Version 1.9 installiert. Ich habe es behoben, indem ich meine installierte Version entfernt und dann die 1.8-Version installiert habe:

aptitude remove Subversion
aptitude install Subversion=1.8.10-6+deb8u1

EDIT
Soweit ich weiß, haben die Entwickler von Android Studio dieses Problem in den neuesten Versionen behoben.

2
Joaquin Iurchuk

In meinem Fall war es mit gebrochenem Pfad verbunden:

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

Problem wurde nach der Installation von xcode-select behoben: xcode-select --install

0
Ihor Kruk