wake-up-neo.net

Beobachtete Paket-ID 'build-tools; 20.0.0' an inkonsistentem Speicherort

  ./gradlew --parallel :app:assembleDebugTest

wenn ich über dem Befehl im Android Studio - Terminal laufe, habe ich diesen Fehler erhalten.

Fehler Parallele Ausführung ist eine Inkubationsfunktion. Beobachtete Paket-ID 'build-tools; 20.0.0' in inkonsistentem Speicherort 'sdk/build-tools/Android-4.4W' (Expected 'sdk/build-tools/20.0.0')

Verlaufsdatei Plugin anwenden: 'com.Android.application'

    Android {
            compileSdkVersion 22
            buildToolsVersion '23.0.2'
            packagingOptions {
                    exclude 'LICENSE.txt'
            }
            defaultConfig {
                    applicationId "package"
                    minSdkVersion 15
                    targetSdkVersion 22
                    versionCode 1
                    versionName "1.0"
                    testApplicationId "package.test"
                    testInstrumentationRunner "package.test.Instrumentation"
            }
            buildTypes {
                    release {
                            minifyEnabled false
                            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
                    }
            }
            sourceSets {
                    androidTest {
                            assets.srcDirs = ['src/androidTest/assets']
                    }
            }
            adbOptions {
                    timeOutInMs 60000 // set timeout to 1 minute
            }
    }

    dependencies {
            compile fileTree(dir: 'libs', include: ['*.jar'])
            compile 'com.Android.support:appcompat-v7:22.2.1'
            compile project(':sdk')
            androidTestCompile('com.Android.support.test:runner:0.4') {
                    exclude module: 'support-annotations'
            }
            androidTestCompile('com.Android.support.test:rules:0.4') {
                    exclude module: 'support-annotations'
            }
            androidTestCompile('com.Android.support.test.espresso:espresso-core:2.2.1') {
                    exclude module: 'support-annotations'
            }

            androidTestCompile 'org.mockito:mockito-core:1.+'
            androidTestCompile 'com.google.dexmaker:dexmaker:1.2'
            androidTestCompile 'com.google.dexmaker:dexmaker-mockito:1.2'
            androidTestCompile('com.Android.support.test.espresso:espresso-contrib:2.2.1') {
                    exclude module: 'support-annotations'
                    exclude group: 'com.Android.support', module: 'appcompat'
                    exclude group: 'com.Android.support', module: 'support-v4'
                    exclude module: 'recyclerview-v7'
            }

            androidTestCompile 'info.cukes:cucumber-Android:[email protected]'
            androidTestCompile 'info.cukes:cucumber-picocontainer:1.2.0'
    }

Referenz: Gurke Android Test Link

14
Jithish P N

Ich hatte gestern denselben Fehler

deinstallieren der build-tools: 20 arbeiteten für mich

antwort auf diese Ausgabe war hilfreich

11
Adeel Javed

benennen Sie den Ordner um 

"sdk/build-tools/Android-4.4W" -> "sdk/build-tools/20.0.0"

4
张文枫

das Umbenennen des Ordners löste mein Problem "sdk/build-tools/Android-4.4W" -> "sdk/build-tools/20.0.0"

0
manish bansal